FAQ – RSMonials (Chinese Language)

March 27, 2012

RS-Monials

rsmonials

Extension Name: RS-Monials | From: ChiBin

Subject: Chinese language

ChiBin: I have a problem where I write a testimonial in Chinese language. However, once submitted, the text is changed to ?????????. It had been tested with different computers and browsers. I can view Chinese language in any other website. Anything i can do to get Chinese testimonial displayed correctly?

Support Team: Thanks for your email. We think you need to change the “Collation” of your database table called “jos_rsmonials”. For this you need to access your database and need to do the needful. If you are not sure then please ask your web developer to do the same. Or if you wish we can also help you in this regards.

ChiBin: Thanks for your feedback. I have fixed it. Just for sharing if any others have this issue.

In my case, changing “Collation” for database via database table setting can’t solved the problem. What I did was alter it using sql query ” ALTER TABLE tablename CONVERT TO CHARACTER SET utf8

This solved the problem. Thanks again for your assist.

[Total: 0    Average: 0/5]
, ,

About Souvik Banerjee

Web Developer and SEO Specialist with 10+ years of experience in open source web development. He is also the moderator of this blog (www.rswebsols.com)

View all posts by Souvik Banerjee

Related Posts

11 Responses to “FAQ – RSMonials (Chinese Language)”

  1. Marianela Says:

    Hi,
    Many thanks for your work.
    We need to show the format posting date like “February 26, 2013″ but it shows “26 February 2013″. Where we should fix this issue?

    We use the 2.0 versión on Joomla 2.5.14.

    Best wishes
    Marianela

    Reply

  2. savan Says:

    Hi,
    in RSmonials it doesn’t support Thai language, what can i do? can you help me this problem ?

    thanks

    Reply

    • Souvik Says:

      Yes, it can support. Please check the database collation of the table as directed in the above FAQ. Also please go to “Joomla Admin” => “Components” => “RSMonials” => “Language File” and edit the respective language file as per your needs.

      Reply

  3. Alberto Says:

    hi, i have the same promblem here! please help…!

    Notice: Undefined index: page in /home5/ingneoor/public_html/inwebmanager/components/com_rsmonials/router.php on line 20

    i have set “display_errors” to “Off”.

    http://inwebmanager.com/

    what can y do?

    Reply

    • Souvik Says:

      Can you please recheck it once? Please do the following:

      1. Login to your Joomla admin panel.
      2. Go to “Site” => “System Information”.
      3. Then go to “PHP Settings” tab.
      4. Check here the “Display Errors” is showing “Off” or “On”.

      If it is showing On then you need to set it Off in your server’s configuration file (i.e. in php.ini file). Otherwise please contact our support team and they will surely help you. Here is the support link: http://www.rswebsols.com/support

      Reply

  4. nicky Says:

    To help, the mistake that goes out for me in the head-board is:

    Notice: Undefined index: page in C:\xampp\htdocs\tingalesesporelmundo\components\com_rsmonials\router.php on line 20

    help!!!!1

    Reply

    • Souvik Says:

      Edit your server’s php.ini file and set “display_errors” to “Off”. Joomla installation also recommends this setting.

      Reply

  5. Seb Says:

    Hi,
    Please make an option for a security question in the rsmonials extension. Visitors are complaining that they cannot identify the captcha, yet without one we get a lot of spam.

    Security Question such as: what is 2+3 or what is the first letter in the word “great”.
    Obviously it would be great to chose our own question.

    AND PLEASE release the 2.5 Version. I’m running two versions of joomla atm, the 1.5 solely for people to leave comments. Even an alpha Version would greatly be appreciated.
    Thanks

    Reply

Leave a Reply