rsmonials

RSMonials FAQ – (Responsive / Mobile-Friendly Scroller Module)

Extension Name: RS-Monials Scroller Module | From: Oliver Leonard

Subject: RSMonials Scroller Module is not Responsive / Mobile friendly.

Oliver Leonard: Hello,

I am using the “RSMonials Scroller” module and wanted to use a percentage for the width so it would be responsive in the template. Is this possible to do?

Thanks for your help.

Support Team: Thank you for your email. It is possible to make the RSMonials Scroller module responsive by adding some custom css code on your template’s css file. Here we are sending you the sample css code. You just need to adjust the “WIDTH” & “HEIGHT” on the css code as per your template’s requirement. Please use it and let us know it is working or not.

/* RSMonials Scroller Module - Responsive CSS - BEGIN */
@media only screen and (min-width: 1200px) {
    #rsmsc_scroller { width: 100% !important; height: 200px !important; }
    #rsmsc_scroller .innerDiv { width: 98% !important; height: 200px !important; }
}

@media only screen and (min-width: 960px) and (max-width: 1199px) {
    #rsmsc_scroller { width: 100% !important; height: 200px !important; }
    #rsmsc_scroller .innerDiv { width: 98% !important; height: 200px !important; }
}

@media only screen and (min-width: 768px) and (max-width: 959px) {
    #rsmsc_scroller { width: 100% !important; height: 250px !important; }
    #rsmsc_scroller .innerDiv { width: 98% !important; height: 250px !important; }
}

@media only screen and (min-width: 481px) and (max-width: 767px) {
    #rsmsc_scroller { width: 100% !important; height: 250px !important; }
    #rsmsc_scroller .innerDiv { width: 98% !important; height: 250px !important; }
}

@media only screen and (max-width: 480px) {
    #rsmsc_scroller { width: 100% !important; height: 300px !important; }
    #rsmsc_scroller .innerDiv { width: 98% !important; height: 300px !important; }
}
/* RSMonials Scroller Module - Responsive CSS - END */

Oliver Leonard: Thank you for the quick response. The css code you supplied worked great! Just had to adjust the width for the innerDiv class a bit to fix the right side overflow but other than that it looks good. Thanks again for your great support.

Support Team: Nice to see it is working. Thank you. If you need any further help in future feel free to contact us using our support form. If you like our extension please rate us at Joomla extension directory (JED).

Disclosure: Some of our articles may contain affiliate links; this means each time you make a purchase, we get a small commission. However, the input we produce is reliable; we always handpick and review all information before publishing it on our website. We can ensure you will always get genuine as well as valuable knowledge and resources.

Recommended Content for you:

Related Articles You May Like:

Article Published by Souvik Banerjee

Web Developer & SEO Specialist with 10+ years of experience in Open Source Web Development, specialized in Joomla & WordPress development. He is also the moderator of this blog "RS Web Solutions".

Comments are closed.

12 thoughts on “RSMonials FAQ – (Responsive / Mobile-Friendly Scroller Module)

  1. Thank you Souvik for your prompt answer and the excellent service.
    I apologize I disturbed you before checking fronted.
    I would like ask you one more thing, Which are the two files I have to increase the characters for the Name? I have found only the one, the rsmonials.php with 50 characters. Which is the second one? Where can I find it?
    Thank you in advance.
    Regards

  2. Hello, mine is not working properly:

    I’m using the rsmonials module and the email notifications when someone leave a testimonial is not working and the when they try to upload a icon picture is also not working?

    Thanks

  3. RsMonials is a very nice extension, congratulations.
    I have a small problem… how can I change date format to dd/mm/yyyy
    I haven’t see anywhere such a setting and if there isn’t any you have to add this option.

    • If you carefully notice, the dd/mm/yyyy format is only used in the admin panel where you edit any testimonials. This is not displaying in front-end. In front-end the format is something like this: “27 January 2016”. So, in any way, your visitor will not see this format.

      We will surely think about the date format more and try to give you more option in our next release.

    • Unfortunately there is no easy option. You need to change in the component code, both in front-end and back-end code. If you are not familiar with Joomla coding, then it is not recommended to change it.

  4. Dear Sirs,
    I still can not solve the problem with RSMonials.
    I have assets in the form and the scroller. The scroller is ok but as you can see at the link on the page testimonies menus are displayed.
    I can not find the solution, I’ve tried everything.
    Can you help me? The support I have received so far has not helped me a lot. I have little experience, I hope that the solution is simple.
    I hope your help.
    http://www.efic-habitat.com/index.php/deja-tu-testimonio
    Elena

    • Hi Elena,

      The problem you are facing is a css issue in your menu configuration. We have noticed one css class called “dropdown-menu” is missing in the sub-menu items for the Testimonials page. That’s why the sub-menu items is displaying all the time. You need to check the menu configuration (In your template OR in your menu module OR in your menu items) so the <Ul> tag of the sub-menu items contain the required css class called “dropdown-menu”.

      If you are not sure how to fix it, you can contact our support team ( http://www.rswebsols.com/support ) and they will surely help you to fix this.

  5. We are using your rsmonials extension. We need an option to suppress the “Posted by:” and “Posted Date” . Having those features is fine for websites that generate a lot of testimonials. But our sales cycle is long intermittent so we need to show our testimonials and not have them be dated by those dates!

    Respectufully,
    Jon

    • Do the following:

      1. Login to Joomla admin panel.

      2. Go to “Components” => “RSMonials” => “CSS File”.

      3. Edit the respective CSS file.

      4. Add the following line of code at the end of the file:

      .RSWS_testmonial_subtext { display: none; }

      5. Save the file.

      6. Then clear your Joomla cache & browser cache (if any) and test your website front-end.