RSMonials – FAQ (ReCaptcha Showing on Top of the Page)

June 21, 2013

RS-Monials

rsmonials

Extension Name: RS-Monials | From: Nathan Stewart

Subject: Security code not displaying on proper section of website.

Nathan: I followed instructions on how to set it up as well as the Google ReCaptcha thing and it is still not displayed properly. My website is ###—URL HIDDEN—###. It is displaying, but it’s at the top of the page and can’t be clicked on. Really weird.

Support Team: The problem is due to some predefined CSS code in your template. To overcome this please do the following:

  1. Login to your Joomla administrator panel.
  2. Go to “Components” => “RSMonials” => “CSS File”.
  3. Edit the respective CSS file.
  4. Add the following line of code at the end of the file: #recaptcha_widget_div { position: relative!important; top: 0px!important; }
  5. Save the css file.
  6. Then test your website after clearing the browser cache.

Nathan: Sweet, thank you. Fixed it.

Support Team: Thank you. If you need any further help in future feel free to contact us using our support form. If you like our extension please rate us at Joomla extension directory (JED).

Note (To our readers): If you have the same issue and if the above solution will not work for you, please comment below along with your website URL. We will provide you the solution as quick as possible.

, , ,

About Souvik Banerjee

Web Developer and SEO Specialist with 10+ years of experience in open source web development. He is also the moderator of this blog (www.rswebsols.com)

View all posts by Souvik Banerjee

Related Posts

Email Subscription

Subscribe to our e-mail newsletter to receive updates.

11 Responses to “RSMonials – FAQ (ReCaptcha Showing on Top of the Page)”

  1. anu Says:

    I have install the rsmonials but it is not showing any parameter in settings tab and nothing is showing

    Reply

    • Souvik Says:

      It seems your installation is not correctly done. Please uninstall the current one and then again install it. his may solve the issue.

      Reply

  2. Luca Maria Terranova Says:

    Hi,
    I try to undo the changes, but doesn’t work.
    If I put he component default captcha image works well.

    Luca

    Reply

    • Luca Maria Terranova Says:

      Hi,
      I try to undo the changes, but doesn’t work.
      If I put he component default captcha image works well.

      Luca

      Reply

    • Souvik Says:

      Actually sometimes due to css conflict with the website template can cause to not display the ReCaptcha properly. So it need to solve css conflict.

      Reply

  3. Luca Terranova Says:

    Hi,
    I have the same problem with google Recaptcha position in the submit form.
    The first time you load the page, the Recaptcha box is displayed at the end of the page, if you reload the page the position is ok ;-)

    This is the page:
    http://www.capodafrica4.com/en/testimonials.html

    Reply

    • Souvik Says:

      Just check your website. It is showing correctly. Did you solved it already?

      Reply

      • Luca Says:

        Hu,
        sorry, i change joomla template of my website and I have the same problem od two mounths ago,.. the recaptcha bos is displayed at the end of the page.
        I try the solution above, but doesn’t work, cau you help me to resolve the problem?
        Thanks in advance
        Luca

        Reply

      • Luca Maria Terranova Says:

        Hi again,
        I change the joomla template and now the the Recaptcha box is displayed at the end of the page …
        this is the url “http://www.capodafrica4.com/en/testimonials.html”,
        can you help me?
        thanks
        luca

        Reply

Leave a Reply

Current ye@r *